Dump Request: A1398 - EMC 2909 - 820-00138-A


Rendering Error in layout Widget/Social: Call to a member function exists() on null. Please enable debug mode for more information.
More
5 months 2 days ago - 5 months 2 days ago #12050 by Sudomin
So it looks like I'm working with a Macbook Pro Retina mid-2015 and my device's original firmware was erased accidentally before I got my hands on it. 
So here I am making a request for information & any dumps you can offer. I can clean it myself if it isn't cleaned already.. but I want to confirm a few things... with those experienced in regards to the process. 

1)Will it boot at all if the serial number is mismatched? Most likely yes, right?
If not I can attempt to modify one of the binary files I have downloaded with the correct serial and see if it works. - I suppose I'll do this while I wait for a response.

Dump Request: Mid-2015 15" MacBookPro Retina A1398 - EMC 2909
Model: A1398
EMC: 2909
Board: 820-00138-A
Chip: MXIC MX25L6473EZNI
Last 4 of serial: G8WN

So far I have tried every or just about every seemingly matching .bin file I have found on the site (locked and unlocked) and haven't been able to get it to boot even to the firmware lock screen. 
From what I have read the 820-00138-A is for the 2.2ghz version of this Macbook Pro Retina Mid-2015

I have written ,read and verified that the chip is indeed getting flashed, but none of the binaries I have tried have made it to the power screen after flashing. 

Typically I have been flashing with the following string or similar
sudo flashrom -p linux_spi:dev=/dev/spidev0.0 -c "MX25L6436E/MX25L6445E/MX25L6465E/MX25L6473E/MX25L6473F" -w bios.bin -VVV

Any help is appreciated.
Flashing with a Raspberry Pi 3B+ and a BIOSACCESS EFI cable 
Thanks,
Sudomin
P.S. Willing to donate to whomever provides a working .bin file locked, or unlocked... As I can edit it myself without a problem. Just need a working base and have yet to find one here or elsewhere that isn't a paysite... Which is realistically my next course of action for a working file.. assuming I strike out here...which the end result will be the same thing as a donation to someone here provided the file/information is usable on my hardware.
Last edit: 5 months 2 days ago by Sudomin. Reason: Additional Information&Bribery

Please Log in or Create an account to join the conversation.

  • .::iRizwan::.
  • .::iRizwan::.'s Avatar
  • Offline
  • Haxor Guru
  • Haxor Guru
  • One Machine can do the work of 50 ordinary men, No Machine can do the work of 1 extraordinary man
More
4 months 4 weeks ago #12058 by .::iRizwan::.
Yes it will work with any Serial.
are you sure that it doesn't have any other issue than EFi.

if i helped you Buy me a Coffee

Please Log in or Create an account to join the conversation.

More
4 months 3 weeks ago - 4 months 3 weeks ago #12075 by Sudomin
Originally it did not, I have seen the laptop boot to the Padlock screen before, so I'm guessing my issue maybe lies in the keyboard or something else not power related per se but definitely related to the power button which as of the moment I believe is not working due to the flex cable that was most likely damaged upon removal or perhaps during reinsertion to board connector. 

Can anyone confirm for me that the power button is "pressed" when: 
Positioning the laptop so the battery  is nearest to you-  you short the 5th pin on the keyboard's flex cable receptacle to ground. 
If that is incorrect, is there another/better way to do it?? (power on without keyboard's power button) 

As of a few days ago I subbed to VIP section @ Dr.Bios.com or whatever and ruled out the possibility that the files were the cause of the failure.

Unless the whole power adapter/magsafe plugged in the chip isn't detected, even on battery power.. Doesn't seem to have any difficulties when flashing once the chip is detected though. After unplugging battery, plugging in SPI SAM cable, plugging in magsafe, and giving it a check seems to be working fine for the write process..
 Also can anyone clarify if my problem lies in not running external power @ 3.3V to somewhere on the board for powering the chip, instead of the magsafe being the power source when flashing... i.e. could the standby power be the potential problem and is causing some sort of issue that could be avoided by directly supplying power @3.3V to the board via the 3.3V rail or any of the points sharing this entire circuit.... center leg of that one chip by the WSON chip...etc.etc..

At the moment if I can't get the thing powered on by shorting a combination of pins or something else clever like that I'll just buy a keyboard, I'm tempted to buy a keyboard immediately and just returning it upon repairs completion if the keyboard isn't actually the faulty component. Either way the keyboard is like $20 so it's not too bad but I would prefer not to have to spend the money if I can avoid it. 

What would you test if you were me?
Thanks!
Last edit: 4 months 3 weeks ago by Sudomin.

Please Log in or Create an account to join the conversation.

Who's Online

We have 162 guests and 2 members online

  • CalnZ
  • dssence

N00BZ

  • CalnZ
  • eldiamante1983
  • Reimonemilio23
  • 5ht6
  • Bobm

Cookies