Dump Request: Macbook Pro (mid-2010) A1278 EMC 2351 MC374LL/A


Rendering Error in layout Widget/Social: Call to a member function exists() on null. Please enable debug mode for more information.
More
6 months 4 days ago - 6 months 2 days ago #12052 by ja3robin
MacbookPro7,1 (mid-2010)
EMC: 2351
Processor: C2D 2.4Ghz
MC374LL/A

This machine does not boot.
All power rails are present and it is giving me a startup chime.
From there I get only a white screen and a fan running at high speed  (no apple logo, no progress bar, no Displayport/HDMI output, can't hold Option to boot from alternate media, can't get to recovery) and sometimes I get just the SOS beep.  I have been able to reset the SMC, but not the PRAM.  Have disconnected the HDD and HDD cable with the hopes of getting at least a question mark folder, but still just a white screen.
I have removed a stick of RAM.  I have removed the RAM completely (then I get a no RAM beep).  I have tried one slot of the other. I have tried other RAM from another machine.  Always either the white screen with no boot indicators, or sometimes the SOS 9 beeps.

I have read out the contents of the current ROM using a Raspberry Pi and flashrom, but I don't know enough about it's structure to tell if it is corrupted or not, but that is the theory that I am exploring now.  I'd like to flash a clean rom to see if I can get some boot activity.

Side note:  I have another working MacBook Pro mid-2010 but with the CS2 2.66Hz processor, running High Sierra, that I was going to dump the rom of, to try on the computer I'm having trouble with, but the eficheck --save - b rom.bin command is not working on that machine, so I can't get my own rom dump from that one.  I get "ReadBinaryFromKernel: No Matching services found.  Either this system is not supported by eficheck, or you need to re-load the kext."  The same command and sequence of steps works on a 2012 Catalina Macbook, so there is something about the High Sierra 2010 Macbook install that isn't working.  And I can't find many instances of the specific problem online.  So if you can help me solve this problem, I can get at least get access to a (very close?) version of the ROM on my own to try.

So I am hoping someone can provide me a dump of for the MC374LL/A listed in the opening paragraph.

Thanks!
Last edit: 6 months 2 days ago by ja3robin. Reason: typo can --> can't

Please Log in or Create an account to join the conversation.

Who's Online

We have 143 guests and no members online

N00BZ

  • XDEVIL2001
  • nerdavaialable
  • patryk-brzezinski
  • yeti
  • bogdan-tudor

Cookies