Anyone willing to help out on a mid 2010 dump


Rendering Error in layout Widget/Social: Call to a member function exists() on null. Please enable debug mode for more information.
More
3 years 9 months ago #6225 by cyber16
I have done several of the newer efi dumps, this is the first time trying an older model.
Tried to run that scan & patch tool, my command line skills I would say are lacking, cant get it to run.
Here is the dump to a mid 2010 15" mbp A1286 ecm 2353
Could someone look at it patch it or tell me that password.?
Again, I have had zero issues with the likes of 2012+ models
Already tried the ram/pram reset without luck
Attachments:

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago - 3 years 9 months ago #6226 by cyber16
Last edit: 3 years 9 months ago by cyber16.

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #6228 by CygnusX1

Cyber16 wrote: Now Trying to use the online tool here ghostlyhaks.com/blog/apple-efi/23-efi-deobfuscate


Did you get it?

If I helped you buy me a latte!

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #6229 by cyber16
No! Still trying to figure this out lol

Attachments:

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago - 3 years 9 months ago #6230 by CygnusX1
Try "J" as the password

If I helped you buy me a latte!
Last edit: 3 years 9 months ago by CygnusX1.

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago - 3 years 9 months ago #6232 by cyber16
Thats what I first though it was a Upper case J but no work, not even the lower case j

May have to figure out that scan & patch tool and patch the firmware and rewrite it, that would mean take the logic board out again.
Anyone know how to use that tool, I have failed on it all day
Last edit: 3 years 9 months ago by cyber16.

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #6233 by cyber16
Do you see that repeat AA 55 7F 00 07 00 00 00 just above and just after all the 00 00 00 00 00......

Anyone willing to run a scan & patch on the dump zip above or understand what the problem is?
The four dumps of the SST chip all verify fine

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago - 3 years 9 months ago #6234 by cyber16
still fighting syntex issues on my PI running an older version of raspbian that I setup about a year ago just for efi
Lets say I place a folder onto my desktop as I have been doing with the use of flashrom.
one of my flashrom read commands looks like this:
flashrom -r /home/pi/Desktop/efi/read1.bin -V -p linux_spi:dev=/dev/spidev0.0

Lets say I dump the contents of the scan-n-patch zip into the same efi flolder on my desktop & want to scan & patch read1.bin
What the heck should my command line read like to scan my dump?

thus far I get file or folder not found, sometimes when close something about no permission.
Last edit: 3 years 9 months ago by cyber16.

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #6235 by CygnusX1

Cyber16 wrote: still fighting syntex issues on my PI running an older version of raspbian that I setup about a year ago just for efi
Lets say I place a folder onto my desktop as I have been doing with the use of flashrom.
one of my flashrom read commands looks like this:
flashrom -r /home/pi/Desktop/efi/read1.bin -V -p linux_spi:dev=/dev/spidev0.0

Lets say I dump the contents of the scan-n-patch zip into the same efi flolder on my desktop & want to scan & patch read1.bin
What the heck should my command line read like to scan my dump?

thus far I get file or folder not found, sometimes when close something about no permission.


Take a look at this

If I helped you buy me a latte!
The following user(s) said Thank You: cyber16

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago - 3 years 9 months ago #6236 by cyber16
thanx been watching it over & over all day.
The closest I get to scanning my dump is a response back bash: ./scan-n-patch.pl: Permission denied

again no problems reading or flashing, just trying scan&patch an already dumped rom. Not sure if it will help, but that letter J is not the password
Last edit: 3 years 9 months ago by cyber16.

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago - 3 years 9 months ago #6238 by cyber16
I did find the product id tag on the top side of the board, this ecm 2353 is the low end basic model i5 2.4ghz, I did not see a clean dump in the downloads.

What would happen if I removed/cleaned that area of "E0 CC CE C3 E4 9A DD 8B" as we would do with newer model units?

looking for ideas? already tried an external keyboard just in case the keyboard is flaky not typing that J correctly

update: I went ahead and just FF out the "E0 CC CE C3 E4 9A DD 8B" & reflashed & verified just fine, It posts just fine BUT still efi locked when I press options to boot to external.

Therefore the password must be elsewhere or I did not get it all. Someone anyone have any ideas, this has now become a challenge for me.
The dump & pix above is from this machine.
Last edit: 3 years 9 months ago by cyber16.

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #6239 by cyber16
thaGH05T says its JfdiN0w!
So its time to re flash on the original dump & try it again.
I will update & THANK YOU thaGH05T
I sure hope it works.

What was I missing? I did see started will a upper case J but then?

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #6240 by thaGH05T
Hey guys, I wrote a tutorial on pre-2011 Macs HERE and have a small decryption tool as well.
The following user(s) said Thank You: cyber16

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #6242 by cyber16
That is the page I linked above & used it, all I got was a upper case J when I pasted in "E0 CC CE C3 E4 9A DD 8B"
I think I did something wrong.
Good news is I now have remove the efi password forever with the help of thaGH05T

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #6243 by thaGH05T
Ahh yes, when I wrote the tool I didn't escape spaces. You have to paste in a string without spaces.
The following user(s) said Thank You: cyber16

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #6245 by cyber16
thank you now I understand MY mistake!

Attachments:

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #6246 by CygnusX1

thaGH05T wrote: Ahh yes, when I wrote the tool I didn't escape spaces. You have to paste in a string without spaces.


Ahh.... no wonder I was getting it wrong. :)

If I helped you buy me a latte!

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago - 3 years 9 months ago #6247 by cyber16
Maybe someone can clean up that rom zip and place it in the downloads Mid 2010 ecm 2353 i5 2.4Ghz dual gpu
Maybe it will be of help to someone later on.
Again, thank you CygnusX1 & thaGH05T ;)

Looks like this old units is worth a rebuild as its in great shape & only needs a HD cable & spinner drive + battery.
Someone will put it to good use, its better then being in the dump/recycler
Last edit: 3 years 9 months ago by cyber16.

Please Log in or Create an account to join the conversation.

More
1 month 6 days ago #12260 by ak8607
Any chance this little tool can get fixed at all. Not returning any password. Thanks. 

Please Log in or Create an account to join the conversation.

Who's Online

We have 123 guests and no members online

N00BZ

  • azunkd113
  • mussa-doumbia
  • mohammad hameed rashid
  • DJMON3y99
  • djmon3y100

Cookies